logo logo

 Back to main page

The NWNX Community Forum

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 
Linux NWNX & 1.69 status
Goto page 1, 2  Next
 
Post new topic   Reply to topic    nwnx.org Forum Index -> Linux development
View previous topic :: View next topic  
Author Message
virusman



Joined: 30 Jan 2005
Posts: 1018
Location: Russia

PostPosted: Sat Mar 29, 2008 1:40    Post subject: Linux NWNX & 1.69 status Reply with quote

Current compatibility status

Working:
NWNX Core 2.7-b4
NWNX ODBC2 0.3
NWNX Chat 0.3.5
NWNX Events 1.2.2
NWNX Functions 1.9.0
NWNX Fixes 1.0.4
NWNX Ruby (since revision 178)

Partially Working:

Not working:


Updating instructions

If you're running Linux, you need to update:
  • NWNX Events to version >= 1.2.2
  • NWNX Chat to version >= 0.3.5
  • NWNX Functions to version >= 1.9.0
  • NWNX Fixes to version >= 1.0.4

If you're running Windows, update:
  • NWNX Chat to version >= 0.3.4
  • NWNX Profiler to version >= 1.6.2
  • NWNX Fixes to version >= 1.0.4


If you're looking for complete list of plugins, here is the link:
http://www.nwnx.org/phpBB2/viewtopic.php?t=1038


Last edited by virusman on Wed Nov 12, 2008 10:18; edited 17 times in total
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
Mikel of Avalon



Joined: 29 Dec 2004
Posts: 72
Location: Germany

PostPosted: Mon Mar 31, 2008 16:20    Post subject: Reply with quote

Get we an update to events, chat and fixes when 1.69 goes final or can't i use these plugins in 1.69?
_________________
Mikel of Avalon

Kalandur - Die vergessene Welt
Back to top
View user's profile Send private message Visit poster's website
virusman



Joined: 30 Jan 2005
Posts: 1018
Location: Russia

PostPosted: Mon Mar 31, 2008 20:19    Post subject: Reply with quote

They will be updated.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
-Asylum-Skitzo



Joined: 16 Mar 2008
Posts: 4

PostPosted: Thu Jul 10, 2008 10:21    Post subject: Reply with quote

As a heads up 1.69 final has been released.
Back to top
View user's profile Send private message
william_hunter



Joined: 31 Jan 2007
Posts: 149

PostPosted: Fri Jul 11, 2008 17:27    Post subject: Reply with quote

nwnx_leto is not causing a crash on my server, FYI.
_________________
The Realm of Tharagon NWN PW
Back to top
View user's profile Send private message
william_hunter



Joined: 31 Jan 2007
Posts: 149

PostPosted: Sat Jul 12, 2008 14:50    Post subject: Reply with quote

I am having crash issues with Events, fyi. I'll get a screenshot next time it happens.
_________________
The Realm of Tharagon NWN PW
Back to top
View user's profile Send private message
william_hunter



Joined: 31 Jan 2007
Posts: 149

PostPosted: Sun Jul 13, 2008 21:03    Post subject: Reply with quote

Screenshot posted in the tech support forums.
_________________
The Realm of Tharagon NWN PW
Back to top
View user's profile Send private message
virusman



Joined: 30 Jan 2005
Posts: 1018
Location: Russia

PostPosted: Mon Jul 14, 2008 17:14    Post subject: Reply with quote

Now everything works except NWNX Ruby.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
Aerisarn



Joined: 11 Mar 2008
Posts: 14

PostPosted: Thu Jul 17, 2008 11:21    Post subject: Reply with quote

I saw some of the nwnexalt code on the acaos branch, is that working, or just a placeholder?
Back to top
View user's profile Send private message
jec2



Joined: 17 Jul 2008
Posts: 49

PostPosted: Thu Jul 17, 2008 15:57    Post subject: EVENTS Plugin 1.2.2 linux Reply with quote

just updated plugins as virusman suggested from his website, getting the following error message:

* Library EVENTS!GET_EVENT_ID does not exist.
* Library EVENTS!GET_EVENT_ID does not exist.
* Library EVENTS!GET_EVENT_ID does not exist.

over and over... any suggestions?
thanks.. Smile

jec.
Back to top
View user's profile Send private message
virusman



Joined: 30 Jan 2005
Posts: 1018
Location: Russia

PostPosted: Thu Jul 17, 2008 17:28    Post subject: Re: EVENTS Plugin 1.2.2 linux Reply with quote

jec2 wrote:
just updated plugins as virusman suggested from his website, getting the following error message:

* Library EVENTS!GET_EVENT_ID does not exist.
* Library EVENTS!GET_EVENT_ID does not exist.
* Library EVENTS!GET_EVENT_ID does not exist.

over and over... any suggestions?
thanks.. Smile

jec.
Please post the logs.0/nwnx_events.txt file contents.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
jec2



Joined: 17 Jul 2008
Posts: 49

PostPosted: Thu Jul 17, 2008 17:34    Post subject: here.. Reply with quote

NWNX Events version 1.2.2 for Linux.
(c) 2006-2008 by virusman (virusman@virusman.ru)
X Could not find SaveChar function or hook failed: 0
X Could not find ActPickPocket function or hook failed: 0
X Could not find ActAttack function or hook failed: 0
X Could not find UseItem function or hook failed: 0
X Could not find ConversationNodeSelect function or hook failed: 0
X Could not find ConditionalScript function or hook failed: 0
X Could not find SendServerToPlayerQuickChatMessage function or hook failed: 0
X Could not find ExamineItem function or hook failed: 0
X Could not find ExamineCreature function or hook failed: 0
X Could not find ExaminePlaceable function or hook failed: 0
X Could not find ExamineDoor function or hook failed: 0
X Could not find UseSkill function or hook failed: 0
X Could not find UseFeat function or hook failed: 0
X Could not find ToggleMode function or hook failed: 0
! RunProc hooked at 8261f94.
Back to top
View user's profile Send private message
virusman



Joined: 30 Jan 2005
Posts: 1018
Location: Russia

PostPosted: Thu Jul 17, 2008 23:12    Post subject: Re: here.. Reply with quote

jec2 wrote:
NWNX Events version 1.2.2 for Linux.
(c) 2006-2008 by virusman (virusman@virusman.ru)
X Could not find SaveChar function or hook failed: 0
X Could not find ActPickPocket function or hook failed: 0
X Could not find ActAttack function or hook failed: 0
X Could not find UseItem function or hook failed: 0
X Could not find ConversationNodeSelect function or hook failed: 0
X Could not find ConditionalScript function or hook failed: 0
X Could not find SendServerToPlayerQuickChatMessage function or hook failed: 0
X Could not find ExamineItem function or hook failed: 0
X Could not find ExamineCreature function or hook failed: 0
X Could not find ExaminePlaceable function or hook failed: 0
X Could not find ExamineDoor function or hook failed: 0
X Could not find UseSkill function or hook failed: 0
X Could not find UseFeat function or hook failed: 0
X Could not find ToggleMode function or hook failed: 0
! RunProc hooked at 8261f94.
You compiled from sources on your machine, right? Is the file AssemblyHelper.cpp present in your sources? If not, please re-download the package. It was updated a few days ago.
Or try the precompiled .so
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
jec2



Joined: 17 Jul 2008
Posts: 49

PostPosted: Fri Jul 18, 2008 2:26    Post subject: using precompiled Reply with quote

hey .. thanks for replying.. Smile
I am using the .so that comes with your latest update released 14 july, 2008. i always use your precompiles, cause while i have all the 32 bit libs and build tools installed, i have trouble configuring and making 32bit in my ubuntu 8.04 64bit OS.. Im sure its easy to do, prolly some swithes involved, but im still learning.. anyway, for now i reverted back to your previous releases .so file, and the error went away..
def. a prob with the plugin its self tho. pretty sure.. anyway.. let me know,

thanks..
jec.
Back to top
View user's profile Send private message
acaos



Joined: 08 May 2007
Posts: 153

PostPosted: Sat Jul 19, 2008 4:06    Post subject: Reply with quote

The eXalt code is part of the fully functional eXalt system. I'm hoping to get the whole thing integrated into NWNX and 1.69 this weekend.

Acaos
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    nwnx.org Forum Index -> Linux development All times are GMT + 2 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group