logo logo

 Back to main page

The NWNX Community Forum

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 
Linux nwnx-plugins/ports by dumbo:ODBC2, ResMan, Chat plugin
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
 
Post new topic   Reply to topic    nwnx.org Forum Index -> Linux development
View previous topic :: View next topic  
Author Message
FunkySwerve



Joined: 02 Jun 2005
Posts: 377

PostPosted: Mon Aug 28, 2006 7:38    Post subject: Reply with quote

Wooot! Thank you very much!
Funky
Back to top
View user's profile Send private message
FunkySwerve



Joined: 02 Jun 2005
Posts: 377

PostPosted: Sat Sep 02, 2006 8:14    Post subject: Reply with quote

Here's SIMTools 2.0! It runs flawlessly in win, but when I put it on my servers with the linux (not bsd) version it truncates messages severely and seemingly randomly. We run debian so we should NOT need the bsd version. Please advise! Was pretty confused since the win port worked. Razz
Thanks,
Funky
Back to top
View user's profile Send private message
virusman



Joined: 30 Jan 2005
Posts: 1014
Location: Russia

PostPosted: Sat Sep 02, 2006 15:02    Post subject: Reply with quote

FunkySwerve wrote:
It runs flawlessly in win, but when I put it on my servers with the linux (not bsd) version it truncates messages severely and seemingly randomly.Funky
What messages? The ones sent by SendMessage or received from players?
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
FunkySwerve



Joined: 02 Jun 2005
Posts: 377

PostPosted: Sat Sep 02, 2006 16:52    Post subject: Reply with quote

The ones sent by SendMessage, sorry, should've been more specific. I have it set up where an invisible critter is located via GetLocalObject, and does a channel 4 SendMessage for every message I wanted to display in the chat window. That includes translations of languages, metachannels, and dm channel fowarding. The creature's name is as single space, because I encountered difficulty when using no name. Setname also caused promblems, though there may have been other issues - all this was in tresting using the Windows plugin on my dev box, and it took about 14 different tries before I got what I wanted.

In Windows version, the creature sends a tell so that the nessage looks like this:

: [Tell] Message

Message is the Players name and playername in purple, then a channel designator in another color, like [Meta] in orange, then text in the channel designator color.

What is happening in Linux version is that some or all of the Message is not making it to the player. The : [Tell] always appears, but sometimes thats all. In other cases, The players first name appears, and other times we saw as much as full name, player name, and channel designator, all correctly colored. None of the messages contained the character. And all worked perfectly in Windows version, which is why I suspect the plugin is the issue rather than the scripts.

Herre are the color codes of the messages, in case the symbols are mucking things up:

const string COLOR_PURPLE = "<c>"; //names
const string COLOR_ORANGE = "<c2>";//(meta)
const string COLOR_BLUE = "<c!}>"; //electrical damage (languages)
const string COLOR_LT_BLUE = "<c>"; //dm channel

I doubt thats it, since all the messages I tested managed to pass the color in some instances, but there they are, in any case.

All other aspects of the plugin, besides SendMessage, appear to be functioning as normal.

Thank you for your time, and your fast response!
Funky
Back to top
View user's profile Send private message
virusman



Joined: 30 Jan 2005
Posts: 1014
Location: Russia

PostPosted: Sat Sep 02, 2006 17:18    Post subject: Reply with quote

FunkySwerve wrote:
The ones sent by SendMessage, sorry, should've been more specific. I have it set up where an invisible critter is located via GetLocalObject, and does a channel 4 SendMessage for every message I wanted to display in the chat window. That includes translations of languages, metachannels, and dm channel fowarding. The creature's name is as single space, because I encountered difficulty when using no name. Setname also caused promblems, though there may have been other issues - all this was in tresting using the Windows plugin on my dev box, and it took about 14 different tries before I got what I wanted.

In Windows version, the creature sends a tell so that the nessage looks like this:

: [Tell] Message

Message is the Players name and playername in purple, then a channel designator in another color, like [Meta] in orange, then text in the channel designator color.

What is happening in Linux version is that some or all of the Message is not making it to the player. The : [Tell] always appears, but sometimes thats all. In other cases, The players first name appears, and other times we saw as much as full name, player name, and channel designator, all correctly colored. None of the messages contained the character. And all worked perfectly in Windows version, which is why I suspect the plugin is the issue rather than the scripts.

Herre are the color codes of the messages, in case the symbols are mucking things up:

const string COLOR_PURPLE = "<c>"; //names
const string COLOR_ORANGE = "<c2>";//(meta)
const string COLOR_BLUE = "<c!}>"; //electrical damage (languages)
const string COLOR_LT_BLUE = "<c>"; //dm channel

I doubt thats it, since all the messages I tested managed to pass the color in some instances, but there they are, in any case.

All other aspects of the plugin, besides SendMessage, appear to be functioning as normal.

Thank you for your time, and your fast response!
Funky
I'll look into it.
In the meantime, try to set debuglevel to 3, look into the log and paste a part of it here. There'll be lines like "o SPEAK: ..., OID: ...", "o SendMsg(...)". This data could be useful.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
FunkySwerve



Joined: 02 Jun 2005
Posts: 377

PostPosted: Sat Sep 02, 2006 20:24    Post subject: Reply with quote

I'll try that. The servers are professionally hosted, however, and I've already set the new SEND_CHANNELS_TO_CHAT_LOG switch to off. I'll switch it back on on one server, and see if I can't vi the ini. Not sure if I have the needed permissions, however. You should be able to replicate the bug with the SIMTools test mod from the link above, as well - it's set to send channels like languages, metachannels, and dm channel forwarding via the SendMessage function by default (messenger autospawns on modload), and HG is running identical scripts.
Thanks,
Funky
Back to top
View user's profile Send private message
virusman



Joined: 30 Jan 2005
Posts: 1014
Location: Russia

PostPosted: Sat Sep 02, 2006 20:52    Post subject: Reply with quote

Fixed.
http://data.virusman.ru/nwn/nwnx_chat-0.2-fixed.rar
Thanks for the bug report.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
FunkySwerve



Joined: 02 Jun 2005
Posts: 377

PostPosted: Sat Sep 02, 2006 23:03    Post subject: Reply with quote

Talk about your fast fixes! Shocked
Thanks again!
Funky
Back to top
View user's profile Send private message
FunkySwerve



Joined: 02 Jun 2005
Posts: 377

PostPosted: Sun Sep 03, 2006 0:23    Post subject: Reply with quote

Just uploaded the fix, stopped the servers, copied it over, restarted then, and they still have the identical issue. Double checked that the plugin I upped was correct, taken from the nwnx_chat-0.2-fixed.rar. Any chance you accidentally put the wrong .so in there? Shows as created around 2:30 pm today, at least...

Funky
Back to top
View user's profile Send private message
virusman



Joined: 30 Jan 2005
Posts: 1014
Location: Russia

PostPosted: Sun Sep 03, 2006 9:41    Post subject: Reply with quote

I compiled the old sources. Razz Laughing Sorry.
Re-uploaded.
http://data.virusman.ru/nwn/nwnx_chat-0.2-fixed.rar
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
FunkySwerve



Joined: 02 Jun 2005
Posts: 377

PostPosted: Sun Sep 03, 2006 16:49    Post subject: Reply with quote

Rofl. Thanks again, in any case!
Funky
Back to top
View user's profile Send private message
Roo



Joined: 28 Jul 2006
Posts: 6

PostPosted: Wed Sep 13, 2006 11:05    Post subject: Reply with quote

Hopefully someone can help with this Confused
What should the plugin be called? When u make it it's called nwnx_odbc.so
Is that right or should it be nwnx_odbc2.so or nwnx_odmbc.so?

Code:
[ODBC2] SetDebugLevel(0) called.  Current value=0
ERROR: ODMBC: OnCreate() failed.


Code:
NWNX2 ODBC2 version 0.3 for Linux.
(c) 2005-2006 by dumbo (dumbo@nm.ru) & virusman (virusman@virusman.ru)
o Critical Error: Datasource must be MySQL.
o Shutdown.


Code:
[ODBC2]
; Log file
MaxLogSize = 512 ; in KByte
LogLevel = 2 ; 0=nothing, 1=only errors, 2=everything

# Use these five settings for MySQL connections
source = mysql
server = localhost
user   = nwn
pwd    = *****
db     = nwn

# Set hookscorco to false if you want to disable hooking of
# StoreCampaignObject and RetrieveCampaignObject entirely

hookscorco = true
Back to top
View user's profile Send private message
Mikel of Avalon



Joined: 29 Dec 2004
Posts: 72
Location: Germany

PostPosted: Wed Sep 13, 2006 14:04    Post subject: Reply with quote

Have you updated the odbc2 plugin to the newest version?

Otherwise you have to change the pwd = keyword to pass = in the nwnx2.ini

Code:

[ODBC2]
; Log file
MaxLogSize = 512 ; in KByte
LogLevel = 2 ; 0=nothing, 1=only errors, 2=everything

# Use these five settings for MySQL connections
source = mysql
server = localhost
user    = nwn
pass   = *****
db     = nwn

# Set hookscorco to false if you want to disable hooking of
# StoreCampaignObject and RetrieveCampaignObject entirely

hookscorco = true

_________________
Mikel of Avalon

Kalandur - Die vergessene Welt
Back to top
View user's profile Send private message Visit poster's website
virusman



Joined: 30 Jan 2005
Posts: 1014
Location: Russia

PostPosted: Wed Sep 13, 2006 14:55    Post subject: Reply with quote

Try to remove spaces in the .ini file:

source=mysql
server=localhost
user=nwn
pwd=*****
db=nwn
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
Roo



Joined: 28 Jul 2006
Posts: 6

PostPosted: Wed Sep 13, 2006 23:13    Post subject: Reply with quote

virusman wrote:
Try to remove spaces in the .ini file:

source=mysql
server=localhost
user=nwn
pwd=*****
db=nwn


That fixed it. Now it just segfaults as soon as it loads though.
Is this one supposed to replace the existing odbc plugin?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    nwnx.org Forum Index -> Linux development All times are GMT + 2 Hours
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 3 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group