logo logo

 Back to main page

The NWNX Community Forum

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 
How to run NWNX4 as a service
Goto page Previous  1, 2
 
Post new topic   Reply to topic    nwnx.org Forum Index -> Technical support
View previous topic :: View next topic  
Author Message
Urlord



Joined: 17 Nov 2006
Posts: 122

PostPosted: Sun Nov 23, 2008 6:50    Post subject: Reply with quote

For the time being I dropped the NWNX4_GUI.exe into my Start Folder, but it would be really nice to figure out why it will not run as a service under Windows XP 64.
_________________
Jim (aka, Urlord)
Visit the Persistent World of Nymri
Back to top
View user's profile Send private message Send e-mail
virusman



Joined: 30 Jan 2005
Posts: 1012
Location: Russia

PostPosted: Sun Nov 23, 2008 9:55    Post subject: Reply with quote

Perhaps because a 32-bit executable cannot be run in 32-bit compatibility mode as a serivce..
Unfortunately, I don't have a 64-bit testing environment.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
Skywing



Joined: 03 Jan 2008
Posts: 321

PostPosted: Tue Nov 25, 2008 0:19    Post subject: Reply with quote

You can run 32-bit services on 64-bit Windows, so that is not the issue. I have had this working with nwnx4 for quite some time (I did need to patch some things on the order of a year or so ago to work around the fact that madchook doesn't work on Windows x64, but that's not an issue with the 1.09 release).

There isn't enough information to discern what's wrong from what has been posted so far.
Back to top
View user's profile Send private message
erikbreau



Joined: 09 Oct 2009
Posts: 23
Location: NB, Canada

PostPosted: Wed Dec 30, 2009 9:28    Post subject: Reply with quote

Hi all.
I am hoping to get some help on this.

I just installed Win7-64bit.
Have NWNX4 running, love it!
It has been suggested that Running it as a Windows Service removes some of the lags the server experiences now and again.

However, I'm confused as to the earlier instructions on how to get this to work as a win-service. Can someone please clarify?

Erik.
_________________
"Europa is coming, and there isn't anything you can do to stop it!..."
http://nwn-europa.blogspot.com/
Europa Pic Gallery: http://picasaweb.google.ca/erikbreau/EuropaPics
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    nwnx.org Forum Index -> Technical support All times are GMT + 2 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group